NUNCA MAIS PASSE RAIVA POR NÃO CONSEGUIR RESOLVER UM PROBLEMA COM O EXCEL - GARANTIDO!

UNIVERSIDADE DO VBA - Domine o VBA no Excel Criando Sistemas Completos - Passo a Passo - CLIQUE AQUI

Você está em: PrincipalArtigosExcel Básico › Capítulo 02 : 02
Quer receber novidades e e-books gratuitos?
« Anterior Δ Página principal ¤ Capítulos Próximo »
CURSO-APOSTILA - APRENDA EXCEL BÁSICO EM 120 LIÇÕES - CURSO COMPLETO - GRATUITO ONLINE
Autor: Júlio Battisti


Lição 022 - Módulo 02 - Operadores em Fórmulas do Excel
Objetivo: Nesta lição vamos tratar sobre os principais operadores que podemos utilizar em fórmulas do Excel. Os operadores especificam o tipo de cálculo que você deseja efetuar nos elementos de uma fórmula. O Microsoft Excel inclui quatro tipos diferentes de operadores de cálculo:  
  • aritméticos
  • de comparação
  • texto
  • referência 

Operadores Aritméticos: 

Os operadores aritméticos efetuam operações matemáticas básicas, como adição, subtração ou multiplicação, combinam números e produzem resultados numéricos. Na tabela a seguir, temos uma descrição dos operadores aritméticos, utilizados em fórmulas do Excel: 

Operador 

Descrição 

Exemplo 

+ 

Adição 

=B2+B3+B4 

- 

Subtração 

=C5-D5 

* 

Multiplicação 

=C5*2 

/ 

Divisão 

=A20/B4 

% 

Porcentagem. Utilizado para especificar porcentagens. Por exemplo, para inserir o valor de cinco por cento em uma célula digite o seguinte: 5% ou 0,05. 

=A2*20% 

ou 

=A2*0,2 

^ 

Exponenciação. É utilizado para elevar o primeiro operando ao expoente definido pelo segundo operando. O seguinte exemplo, eleva 2 no expoente 3: =2^3 

=A2^B2 

Operadores de Comparação: 

Os operadores de comparação comparam dois valores e produzem o valor lógico VERDADEIRO ou FALSO . Por exemplo se utilizarmos a seguinte fórmula: 

=F2<F5 

Se o valor contido na célula F2 for menor do que o valor contido na célula F5, a fórmula irá retornar VERDADEIRO , caso contrário, irá retornarFALSO . A seguir a descrição dos operadores de comparação disponíveis no Excel: 

Operador

Descrição 

Exemplo 

= 

Igual 

Retorna verdadeiro quando os dois valores forem iguais 

=F2=F5 

> 

Maior do que 

Retorna verdadeiro quando o primeiro valor for maior do que o segundo. 

=F2>F5 

< 

Menor do que 

Retorna menor quando o primeiro valor for menor do que o segundo. 

=F2<F5 

>= 

Maior ou igual a 

Retorna verdadeiro quando o primeiro valor for maior ou igual ao segundo. 

=F2>=F5 

<= 

Menor ou igual a 

Retorna verdadeiro quando o primeiro valor for menor ou igual ao segundo. 

=F2<=F5 

<> 

Diferente 

Retorna verdadeiro quando os dois valores comparados forem diferentes 

=F2<>F5 

Operadores de Texto: 

O operador de texto & é utilizado para concatenar (juntar) texto. Por exemplo, se tivermos o nome do contribuinte na coluna A e o sobrenome na coluna B, podemos utilizar o operador & , para gerar o nome completo na coluna C. Para isso utilizaríamos a seguinte fórmula: 

=A1 & " " & B1 

Observe que utilizamos um espaço em branco entre aspas (" "). Este espaço em branco é utilizado para que o sobrenome não fique " grudado " com o nome. Utilizamos o operador &, para concatenar as diferentes partes que formam o nome completo: 

1. O nome que está na coluna A. 

2. Um espaço em branco (" "). 

3. O sobrenome que está na coluna B. 

Operadores de Referência: 

Os operadores de referência combinam intervalos de células para cálculos. 

Operador : (dois-pontos)->Operador de intervalo : Produz uma referência a todas as células entre duas referências, incluindo as duas referências, como por exemplo: B5 : B15 . Utilizaremos este operador quando aprendermos a utilizar fórmulas no Excel. Apenas a título de exemplo, considere a fórmula: =SOMA( A1 : A30 ). Esta fórmula irá retornar a soma de todos os valores contidos na faixa de célula A1 até A30. Esta fórmula é equivalente a seguinte fórmula: 

=A1+A2+A3+A4+A5+A6+A7+A8+A9+A10+A11+A12+A13+A14+A15 

+A16+A17+A18+A19+A20+A21+A22+A23 

+A24+A25+A26+A27+A28+A29+A30 

Operador união ";" ( ponto e vírgula) : Este operador é utilizado para "unir" vários intervalos de células, de tal forma que os mesmos sejam tratados como um único intervalo. Por exemplo, para somarmos os valores dos intervalos B5:B15 , mais os valores do intervalo C32:C200 mais o valor da célula X45 , utilizamos a seguinte fórmula: 

=SOMA(B5:B15;C32:C200;X45) 


« Anterior Δ Página principal ¤ Capítulos Próximo »
Quer receber novidades e e-books gratuitos?

Cursos Online

  • Banco de Dados
  • Carreira
  • Criação/Web
  • Excel/Projetos
  • Formação
  • + Todas as categorias
  • Contato: Telefone: (51) 3717-3796 | E-mail: webmaster@juliobattisti.com.br | Whatsapp: (51) 99627-3434

    Júlio Battisti Livros e Cursos Ltda | CNPJ: 08.916.484/0001-25 | Rua Vereador Ivo Cláudio Weigel, 537 - Universitário, Santa Cruz do Sul/RS, CEP: 96816-208

    Todos os direitos reservados, Júlio Battisti 2001-2019 ®

    [LIVRO]: MACROS E PROGRAMAÇÃO VBA NO EXCEL 2010 - PASSO-A-PASSO

    APRENDA COM JULIO BATTISTI - 1124 PÁGINAS: CLIQUE AQUI