NUNCA MAIS PASSE RAIVA POR NÃO CONSEGUIR RESOLVER UM PROBLEMA COM O EXCEL - GARANTIDO!

UNIVERSIDADE DO VBA - Domine o VBA no Excel Criando Sistemas Completos - Passo a Passo - CLIQUE AQUI

Você está em: PrincipalArtigosExcel Básico › Capítulo 02 : 05
Quer receber novidades e e-books gratuitos?
« Anterior Δ Página principal ¤ Capítulos Próximo »
CURSO-APOSTILA - APRENDA EXCEL BÁSICO EM 120 LIÇÕES - CURSO COMPLETO - GRATUITO ONLINE
Autor: Júlio Battisti


Lição 025 - Módulo 02 - Fórmulas no Excel - Introdução
Objetivo: Nesta lição veremos como a utilização das funções do Excel pode facilitar, bastante, a realização de cálculos em planilhas. Apresentaremos o conceito de função, bem coma a sintaxe básica para a utilização de funções. 

O uso de funções: 

Uma função é uma fórmula especial, pré-definida, que toma um ou mais valores (os parâmetros), executa uma operação e produz um valor ou valores. As funções podem ser usadas isoladamente ou como bloco de construção de outras fórmulas. O uso de funções simplifica as planilhas, especialmente aquelas que realizam cálculos extensos e complexos. Por exemplo, ao invés de digitar a fórmula =A1+A2+A3+A4+...+A200 , você pode usar a função SOMA(A1:A200) , para calcular a soma das células do intervalo entre a célula A1 e a célula A200. 

Se uma função aparecer no início de uma fórmula, anteceda-a com um sinal de igual, como em qualquer fórmula. Os parênteses informam ao Excel onde os argumentos iniciam e terminam, lembre-se de que não pode haver espaço antes ou depois dos parênteses. Os argumentos podem ser números, textos, valores lógicos ou referências. 

Para usar uma função, basta incluí-la nas fórmulas da planilha. A seqüência de caracteres usada em uma função é chamada sintaxe. Todas as funções têm basicamente a mesma sintaxe. Se você não seguir esta sintaxe, o Microsoft Excel exibirá uma mensagem indicando que há um erro na fórmula. Seja qual for o tipo de fórmula, ao incluir uma função no início de uma fórmula, inclua um sinal de igual antes da função. 

Os argumentos são especificados sempre dentro dos parênteses. Os argumentos podem ser números, texto, valores lógicos, matrizes, valores de erro ou referências a uma célula ou faixa de células. Para que o argumento seja válido, é preciso que ele gere um valor válido. Algumas funções aceitam argumentos opcionais, não necessários para que a função execute os cálculos. 

Os argumentos também podem ser constantes ou fórmulas. As fórmulas podem conter outras funções. Uma função que tem como argumento uma outra função é chamada função aninhada. No Microsoft Excel, você pode aninhar até sete níveis de funções em uma fórmula . Veremos exemplos de funções aninhadas no decorrer deste curso. 

As funções são fórmulas predefinidas que efetuam cálculos usando valores específicos, denominados argumentos, em uma determinada ordem, denominada sintaxe. Por exemplo, a função SOMA() adiciona valores ou intervalos de células, e a função PGTO() calcula os pagamentos deempréstimos com base em uma taxa de juros, na extensão do empréstimo e no valor principal do empréstimo. 

Os argumentos podem ser números, texto, valores lógicos como VERDADEIRO ou FALSO, matrizes, valores de erro como #N/D, ou referências de célula. O argumento atribuído deve produzir um valor válido para este argumento. Os argumentos também podem ser constantes, fórmulas ou outras funções. 

A sintaxe de uma função começa com o nome da função, seguido de um parêntese de abertura, os argumentos da função separados por ponto-e-vírgula (;) e um parêntese de fechamento. Se a função iniciar uma fórmula, digite um sinal de igual (=) antes do nome da função. Esta sintaxe não possui exceções, ou seja: 

1. Em primeiro lugar vem o nome da função e uma abertura de parênteses. Por Ex. =Soma( 

2. Em seguida vem uma lista de parâmetros separados por ponto-e-vírgula (;). O número de parâmetros varia de função para função. Algumas possuem um único parâmetro, outras possuem dois ou mais parâmetros e assim por diante. Por exemplo, a função soma pode conter, no mínimo, um parâmetro e, no máximo, trinta parâmetros. Por Ex. =Soma(A1;C3;F4) . Esta fórmula retorna o valor da soma dos valores das células passadas como parâmetros, ou seja, esta fórmula é equivalente à: =A1+C3+F4. 

3. Após a lista de parâmetros fechamos o parênteses. Por Ex. =Soma(A1;C3;F4) . Agora nossa fórmula está completa. 

Na tabela a seguir temos mais alguns exemplos de utilização da função SOMA(). 

Exemplo - função SOMA 

Descrição 

=SOMA(A1:A20) 

Soma dos valores no intervalo de células de A1 até A20. 

=SOMA(A1:A20;C23) 

Soma dos valores no intervalo de células de A1 até A20, mais o valor da célula C23. 

=SOMA(A1:A20;C23;235) 

Soma dos valores no intervalo de células de A1 até A20, mais o valor da célula C23, mais o valor 235, o qual foi passado diretamente como parâmetro.

=SOMA(A1:A20;C10:C50) 

Soma dos valores no intervalo de células de A1 até A20 mais os valores do intervalo de C10 até C50. 

Na tabela a seguir temos mais alguns exemplos de utilização da função SOMA().


« Anterior Δ Página principal ¤ Capítulos Próximo »
Quer receber novidades e e-books gratuitos?

Cursos Online

  • Banco de Dados
  • Carreira
  • Criação/Web
  • Excel/Projetos
  • Formação
  • + Todas as categorias
  • Contato: Telefone: (51) 3717-3796 | E-mail: webmaster@juliobattisti.com.br | Whatsapp: (51) 99627-3434

    Júlio Battisti Livros e Cursos Ltda | CNPJ: 08.916.484/0001-25 | Rua Vereador Ivo Cláudio Weigel, 537 - Universitário, Santa Cruz do Sul/RS, CEP: 96816-208

    Todos os direitos reservados, Júlio Battisti 2001-2019 ®

    [LIVRO]: MACROS E PROGRAMAÇÃO VBA NO EXCEL 2010 - PASSO-A-PASSO

    APRENDA COM JULIO BATTISTI - 1124 PÁGINAS: CLIQUE AQUI