NUNCA MAIS PASSE RAIVA POR NÃO CONSEGUIR RESOLVER UM PROBLEMA COM O EXCEL - GARANTIDO!

UNIVERSIDADE DO VBA - Domine o VBA no Excel Criando Sistemas Completos - Passo a Passo - CLIQUE AQUI

Você está em: PrincipalArtigosExcel Básico › Capítulo 02 : 07
Quer receber novidades e e-books gratuitos?
« Anterior Δ Página principal ¤ Capítulos Próximo »
CURSO-APOSTILA - APRENDA EXCEL BÁSICO EM 120 LIÇÕES - CURSO COMPLETO - GRATUITO ONLINE
Autor: Júlio Battisti


Lição 027 - Módulo 02 - Funções básicas do Excel - Parte II
Objetivo: Vamos aprender algumas funções básicas do Excel. Neste lição aprenderemos a utilizar as seguintes funções: 

§ SE() 

§ CONT.VALORES() 

§ CONT.SE() 

§ SOMASE() 

=SE(teste;valor_verdadeiro;valor_falso) 

Esta função retorna o valor definido no parâmetro " valor_se_verdadeiro " se o resultado do teste for verdadeiro ou o valor definido no parâmetro " valor_se_falso " se o resultado do teste for falso. Utilize a função =SE() para fazer testes condicionais de fórmulas e valores de células. 

Sintaxe: =SE(teste;valor_se_verdadeiro;valor_se_falso) 

Se omitido valor_se_falso será retornado Falso. O resultado do teste determinará o valor devolvido pela função =SE(). Os argumentos valor_se_verdadeiro e valor_se_falso poderão ser qualquer valor ou teste lógico. Podem ser encadeadas até sete funções =SE() como argumentos valor_se_verdadeiro e valor_se_falso para construir testes mais elaborados. Veremos esta técnica nos exemplos dos próximos módulos. 

Se você deseja emitir uma mensagem no resultado da condição, a mensagem deve ser colocada entre aspas, assim ao invés de ser executada uma determinada fórmula, será exibida uma mensagem para o usuário. 

Exemplos: 

=SE(VERDADEIRO;1;2) 
retorna 1 


=SE(FALSO;1;2) 
retorna 2 
=SE(A1<5;10;20) 


SE A1 for igual à 3 retorna 10 
SE A1 for igual à 8 retorna 20 


=CONT.VALORES(intervalo1;intervalo2;...;intervalon) 

Esta função conta a quantidade de valores contida na lista de argumentos ou no intervalo das células especificadas como argumento. Esta função aceita de 1 a 30 argumentos. Os argumentos devem ser números, ou matrizes ou referências que contenham números. 

Sintaxe: =CONT.VALORES(valor1;valor2;intervalo1;...) 

Exemplo: 

Se todas as células em A1:A10 contiverem dados, quer seja números, textos ou qualquer outro dado, exceto a célula A3, então: 

=CONT.VALORES(A1:A10) --> resulta 9 

=CONT.SE( ) 

Esta função conta de acordo com um critério definido. Por exemplo, em uma planilha com dados sobre os funcionários, posso querer contar quantos funcionários estão locados para o departamento de Contabilidade. Posso usar a função CONT.SE, para, a partir da coluna Seção, contar quantos funcionários pertencem ao departamento de Contabilidade. 

Sintaxe: =CONT.SE(FAIXA;Critério) 

Exemplo: 

Se na faixa de B2 até B50 tivermos 10 vezes a palavra CONTAB, indicando que o funcionário é da Contabilidade, então: 

=CONT.SE(B2:B50;"CONTAB") --> Retorna 10 

NOTA: O critério deve vir sempre entre aspas, mesmo que seja um teste numérico. Por exemplo, para contar quantos valores, maiores do que 20, existem na faixa de A1 até A50, utilizamos a seguinte fórmula  

=CONT.SE(A1:A50; " >20 " ). 

=SOMASE( ) 

Esta função procura em uma coluna por determinados valores (Por exemplo, procura em uma coluna pela Seção do funcionário), e caso encontre o valor procurado, utiliza os valores de outra coluna para ir somando. Por exemplo, em uma planilha com dados sobre os funcionários, posso querer somar o total de Salários para todos os funcionários que estão locados para o departamento de Contabilidade. Posso usar a funçãoSOMASE() , para a partir da coluna Seção, verificar os funcionários que pertencem a Contabilidade (CONTAB) e somar os respectivos salários na coluna de Salários. 

Sintaxe: =SOMASE(FAIXA_DE_TESTE;Critério;FAIXA_VALORES_A_SOMAR) 

Exemplo: 

Se na faixa de B2 até B50 tivermos 10 vezes a palavra CONTAB, indicando que o funcionário é da Contabilidade, e na coluna F, de F2 até F50, tivermos as informações sobre o salário, então: 

=SOMASE(B2:B50;"CONTAB";F2:F50) 

Retorna a soma dos Salários dos 10 Funcionários da Contabilidade. Em resumo, procura na faixa de B2:B50 pela palavra CONTAB, ao encontrar, desloca-se para a coluna F (onde está o valor dos salários) e vai somando os valores dos salários para os funcionários do departamento de Contabilidade.


« Anterior Δ Página principal ¤ Capítulos Próximo »
Quer receber novidades e e-books gratuitos?

Cursos Online

  • Banco de Dados
  • Carreira
  • Criação/Web
  • Excel/Projetos
  • Formação
  • + Todas as categorias
  • Contato: Telefone: (51) 3717-3796 | E-mail: webmaster@juliobattisti.com.br | Whatsapp: (51) 99627-3434

    Júlio Battisti Livros e Cursos Ltda | CNPJ: 08.916.484/0001-25 | Rua Vereador Ivo Cláudio Weigel, 537 - Universitário, Santa Cruz do Sul/RS, CEP: 96816-208

    Todos os direitos reservados, Júlio Battisti 2001-2019 ®

    [LIVRO]: MACROS E PROGRAMAÇÃO VBA NO EXCEL 2010 - PASSO-A-PASSO

    APRENDA COM JULIO BATTISTI - 1124 PÁGINAS: CLIQUE AQUI