NUNCA MAIS PASSE RAIVA POR NÃO CONSEGUIR RESOLVER UM PROBLEMA COM O EXCEL - GARANTIDO!

UNIVERSIDADE DO VBA - Domine o VBA no Excel Criando Sistemas Completos - Passo a Passo - CLIQUE AQUI

Você está em: PrincipalArtigosExcel Básico › Capítulo 02 : 15
Quer receber novidades e e-books gratuitos?
« Anterior Δ Página principal ¤ Capítulos Próximo »
CURSO-APOSTILA - APRENDA EXCEL BÁSICO EM 120 LIÇÕES - CURSO COMPLETO - GRATUITO ONLINE
Autor: Júlio Battisti


Lição 035 - Módulo 02 - Resolução do Exemplo 4
Objetivo: A seguir apresento a resolução para o exercício da Lição Anterior, onde detalho o funcionamento das funções: 

· CONT.SE() 

· SOMASE() 

Nota : As funções Soma(), Máximo(), Mínimo() e Média() não serão detalhadas nesta resolução, pois já foram detalhadamente explicadas em lições anteriores. 

Resolução do Exemplo 4: 

1. Abra a planilha Modulo 2 - Lição 14.xls , criada na lição anterior . 

2. Na célula C26, vamos utilizar a função CONT.SE (), para determinar o número de funcionários pertencentes à seção de Administração (ADM). Se tivéssemos que fazer esta contagem manualmente, o que faríamos? Iríamos na coluna C, onde está a informação sobre a seção do funcionário, e contaríamos quantos ADM existem nesta coluna. É exatamente isto que a função CONT.SE() faz, só que de maneira automática. Passamos dois parâmetros para a função CONT.SE() : O primeiro parâmetro é a faixa a ser pesquisada (no nosso exemplo é de C5 à C17-> C5:C17 ). O segundo parâmetro é o critério a ser pesquisado (no nosso exemplo "ADM"). Um detalhe importante é que o critério deve sempre vir entre aspas ("), mesmo que o critério seja numérico. Digite a seguinte fórmula na Célula C26:  

=CONT.SE(C5:C17;" ADM ") 

3. Para as demais células, a fórmula é a mesma, apenas alterando o critério. 

4. Para determinar o número de funcionários da Contabilidade (CONTAB), digite a seguinte fórmula na Célula D26:  

=CONT.SE(C5:C17;" CONTAB ") 

5. Para determinar o número de funcionários da seção de Finanças (FINAN), digite a seguinte fórmula na Célula E26: 

=CONT.SE(C5:C17;" FINAN ") 

6. Agora vamos passar ao cálculo da soma dos salários de cada seção. 

7. Na célula C27, vamos utilizar a função SOMASE() , para determinar a soma dos salários de funcionários pertencentes à seção de Administração (ADM). Se tivéssemos que fazer esta soma manualmente, o que faríamos? Iríamos na coluna C, onde está a informação sobre a seção do funcionário, verificaríamos se a seção é ADM, se for ADM iríamos na coluna B e passaríamos a somar o respectivo valor de salário . É exatamente isto que a função SOMASE() faz, só que de maneira automática. Passamos três parâmetros para a função SOMASE() : O primeiro parâmetro é a faixa a ser pesquisada onde estão as informações sobre a seção (no nosso exemplo é C5:C17). O segundo parâmetro é o critério a ser pesquisado (no nosso exemplo "ADM"). Um detalhe importante é que o critério deve, sempre, vir entre aspas ("), mesmo que o critério seja numérico. O terceiro parâmetro é a faixa onde estão os valores a serem somados (no nosso exemplo é B5:B17). Para calcular a soma dos salários dos funcionários da Administração, digite a seguinte fórmula na Célula C27:  

=SOMASE(C5:C17;" ADM ";B5:B17) 

8. Para as demais células, a fórmula é a mesma, apenas devemos alterar o critério. 

9. Para calcular a soma dos salários dos funcionários da Contabilidade (CONTAB), digite a seguinte fórmula na Célula D27: 

=SOMASE(C5:C17;" CONTAB ";B5: B17 ) 

10. Para calcular a soma dos salários dos funcionários da seção de Finanças (FINAN), digite a seguinte fórmula na Célula E27: 

=SOMASE(C5:C17;" FINAN ";B5:B17) 

11. Você deve obter os resultados indicados na figura a seguir: 

Excel Básico em 120 Lições - Júlio Battisti


« Anterior Δ Página principal ¤ Capítulos Próximo »
Quer receber novidades e e-books gratuitos?

Cursos Online

  • Banco de Dados
  • Carreira
  • Criação/Web
  • Excel/Projetos
  • Formação
  • + Todas as categorias
  • Contato: Telefone: (51) 3717-3796 | E-mail: webmaster@juliobattisti.com.br | Whatsapp: (51) 99627-3434

    Júlio Battisti Livros e Cursos Ltda | CNPJ: 08.916.484/0001-25 | Rua Vereador Ivo Cláudio Weigel, 537 - Universitário, Santa Cruz do Sul/RS, CEP: 96816-208

    Todos os direitos reservados, Júlio Battisti 2001-2019 ®

    [LIVRO]: MACROS E PROGRAMAÇÃO VBA NO EXCEL 2010 - PASSO-A-PASSO

    APRENDA COM JULIO BATTISTI - 1124 PÁGINAS: CLIQUE AQUI