NUNCA MAIS PASSE RAIVA POR NÃO CONSEGUIR RESOLVER UM PROBLEMA COM O EXCEL - GARANTIDO!

UNIVERSIDADE DO VBA - Domine o VBA no Excel Criando Sistemas Completos - Passo a Passo - CLIQUE AQUI

Você está em: PrincipalArtigosExcel Básico › Capítulo 04 : 14
Quer receber novidades e e-books gratuitos?
« Anterior Δ Página principal ¤ Capítulos Próximo »
CURSO-APOSTILA - APRENDA EXCEL BÁSICO EM 120 LIÇÕES - CURSO COMPLETO - GRATUITO ONLINE
Autor: Júlio Battisti


Lição 074 - Módulo 04 - Exemplo com funções de texto
Objetivo: Nesta lição iremos propor um exemplo que utiliza as seguintes funções de texto: 
  • SUBSTITUIR()
  • EXT.TEXTO()
  • Funções SE Aninhadas 

Exemplo proposto: 

Vamos criar uma planilha na qual efetuaremos alguns cálculos. Nesta lição criaremos a planilha Modulo 4 - Lição 14.xls e salvaremos a planilha na pasta C:\Meus documentos\Curso Excel 97\Exercicios\Modulo4 . 

Para criar a planilha Modulo 4 - Lição 14.xls faça o seguinte: 

1. Abra o Excel (Iniciar -> Programas -> Microsoft Excel). 

2. Será aberta uma pasta de trabalho em branco (Pasta1.xls). 

3. Digite as informações indicadas na Figura a seguir: 

Excel Básico em 120 Lições - Júlio Battisti

4. A coluna Código contém o número de matrícula de cada funcionário. Devido a uma reestruturação da empresa precisamos substituir o dígito 99 pelo dígito 3003. Por exemplo, a matrícula para o funcionário José da Silva deve ser alterada de 1536-99-20 para 15-36-3003-20 . Para fazer esta mudança, automaticamente, para todos os funcionários utilizaremos a função Substituir() . Utilizaremos esta função na coluna C, onde serão exibidas as novas matrículas. 

Observe que o dígito 99 inicia na posição 6, pois antes temos quatro dígitos mais o tracinho (-). Para fazer esta substituição digite, na célula C2, a seguinte fórmula: 

=SUBSTITUIR(B2; "-99-"; "-3003-") 

Observe que utilizamos -99- e não apenas 99. Fizemos isto para que não fosse substituído um valor 99 no início ou no final do código. Se não fizéssemos isso poderíamos ter erros como o seguinte: O código 5599-99-35 seria substituído por 553003-3003-35 . Observe que as duas ocorrências de 99 foram substituídas. Para o nosso exemplo somente queremos que seja substituída a ocorrência que está entre os dois traços, por isso utilizamos -99-. 

Estenda esta fórmula para as demais linhas. 

5. Utilize funções SE Aninhadas, para determinar o valor do Adicional, na coluna E, de acordo com os critérios da tabela a seguir: 

Penúltimo dígito da nova matrícula  Adicional 

2 

250 

3 

100 

4 

500 

Agora temos uma importante questão a considerar:"Precisamos testar apenas o valor do penúltimo digito e não a matrícula inteira. Neste caso, como fazer para extrair apenas o penúltimo dígito da nova matrícula?" 

A resposta à esta questão é simples. Utilizamos a função EXT.TEXTO() para retornar apenas o penúltimo dígito. Observe que, contando a partir do início, o penúltimo dígito está na posição 11, pois temos 4 dígitos, mais um tracinho, mais quatro dígitos e mais um tracinho, totalizando 10 posições. 

No nosso exemplo vamos utilizar a função EXT.TEXTO() , dentro da função SE. A função EXT.TEXTO() retorna o penúltimo dígito da matrícula. Utilizamos o valor retornado pela função EXT.TEXTO() e comparamos o seu valor para determinar se o mesmo é 2, 3 ou 4. Com base neste valor retornamos o valor do Adicional correspondente. 

A seguir temos a parte inicial da fórmula: 

=SE(EXT.TEXTO(C2;11;1)="2";250 

Vamos a mais alguns detalhes importantes sobre esta parte inicial da fórmula. Quando esta fórmula é executada pelo Excel, em primeiro lugar é executada a função EXT.TEXTO() , a qual " pega " o valor da célula C2 e retorna, a partir da posição 11, um caractere. Observe que o parâmetro 1, dentro do parênteses é que indica que queremos apenas um dígito. Este dígito, retornado pela função EXT.TEXTO, é comparado com o valor "2". Observe que colocamos o "2" entre aspas, pois a função EXT.TEXTO() retorna não o número inteiro 2, mas sim o caractere de texto "2". No exemplo da nossa planilha, a função EXT.TEXTO(C2;11;1) , para a linha 2, retornará o valor "2", o qual é comparado com o "2" que está à direita do sinal de igualdade. Como os valores são correspondentes, o Adicional retornado será 250. 

Agora precisamos continuar a nossa fórmula, para incluir os testes para as demais possibilidades, ou seja: 3 ou 4. Lembrando que como temos três possibilidades precisamos fazer apenas dois testes - o número de testes é igual ao número de possibilidades menos um . No nosso exemplo vamos testar se o penúltimo dígito é igual a 3. Não precisamos fazer o teste para ver se é igual a 4, pois se não for igual a 2 ou 3 só pode ser igual a 4 - no nosso exemplo. Completando a nossa fórmula, teríamos o seguinte: 

=SE(EXT.TEXTO(C2;11;1)="2";250;SE(EXT.TEXTO(C2;11;1)="3";100;500)) 

Estenda esta fórmula para as demais linhas. 

6. Na coluna F, calcule o Salário Líquido. Para isso adicione o valor da coluna Adicional (coluna E) ao valor da coluna Sal. Base (coluna D).  

Na célula F2 digite a seguinte fórmula:  

=D2+E2 

Estenda esta fórmula para as demais linhas. 

7. Formate as colunas C, D, E e F com o formato Contábil, com duas casas decimais. Observe que neste formato, as células que possuem valor igual a zero exibem um traço - . 

8. Feito isso você deve obter os resultados indicados na figura a seguir: 

Excel Básico em 120 Lições - Júlio Battisti

9. Agora vamos salvar a planilha. 

10. Selecione o comando Arquivo -> Salvar Como . Surge a janela Salvar Como. 

11. Utilize a lista Salvar em , para navegar até a pasta C:\Meus documentos\Curso Excel 97\Exercicios\Modulo4 . 

12. No campo Nome do arquivo:, digite Modulo 4 - Lição 14.xls . Sua janela deve estar conforme indicado na Figura a seguir: 

Excel Básico em 120 Lições - Júlio Battisti

13. Clique no botão Salvar. 

14. Feche o Microsoft Excel.


« Anterior Δ Página principal ¤ Capítulos Próximo »
Quer receber novidades e e-books gratuitos?

Cursos Online

  • Banco de Dados
  • Carreira
  • Criação/Web
  • Excel/Projetos
  • Formação
  • + Todas as categorias
  • Contato: Telefone: (51) 3717-3796 | E-mail: webmaster@juliobattisti.com.br | Whatsapp: (51) 99627-3434

    Júlio Battisti Livros e Cursos Ltda | CNPJ: 08.916.484/0001-25 | Rua Vereador Ivo Cláudio Weigel, 537 - Universitário, Santa Cruz do Sul/RS, CEP: 96816-208

    Todos os direitos reservados, Júlio Battisti 2001-2019 ®

    [LIVRO]: MACROS E PROGRAMAÇÃO VBA NO EXCEL 2010 - PASSO-A-PASSO

    APRENDA COM JULIO BATTISTI - 1124 PÁGINAS: CLIQUE AQUI